Inventory Discrepancies

Modified on Sun, 16 Jun at 11:07 PM

Overview

Our track record with regard to accuracy for inventory on hand, and valuation is unparalleled.  It has taken us years, working with dozens and dozens of customer files to ensure that our logic is correct.  Intuit does not give developers direct access to inventory information.


Yet there are cases where the data may not match to QuickBooks.


Cause

  1. Synch Issues
  2. Mismatched filters comparing QuickBooks to QQube
  3. Enhanced Receiving and Bills not filtered out
  4. Quantity errors from very old QuickBooks files
  5. Total Valuation because of Cause 4.
  6. Valuation by Site calculation different between QQube and QuickBooks
  7. Serial Numbers not matching quantity


Resolution


Cause 1. Checking the synch logs is always the first place to start.  Synch errors must always be attended to.  Just because you see successful synchs after an error, it does not mean that the error magically fixed itself.  Most times a run all / clear all is necessary and fixes all observations of data discrepancies - especially if your reports were previously accurate for a long period of time.



Cause 2. The two most common filters to check are:

  • Active/Inactive items. Before making an item inactive, there should never be a balance, whether negative or positive. You should make the necessary inventory adjustments before marking an item inactive.
  • Posting Status.  Document Current Posting State should always be "Posted" in QQube, otherwise you will pick up pending transactions.


Cause 3. For Enhanced Receiving, filter out Document Transaction Type = "Bill" This is because the inventory is accrued via item receipts in enhanced receiving.


Cause 4. In the early years of QuickBooks it was possible to have a null value and an amount - among other scenarios.  Over that time, QuickBooks has closed many of those holes, so that "1" means "1".  We always tell customers:  "what you put in, is what comes out".   For instance, having a "0" and an amount > 0 actually means "1" or does it?


Cause 5. QQube arrives at valuation differently than QB reports - although the final results usually match to the penny.  The possibilities of Cause 4 can also be responsible for an improper valuation. 

  • QQube generates its valuation by grabbing the actual posting amounts for each transaction.
  • QuickBooks takes the current quantity and multiplies it by the current average cost.


Since the Intuit SDK doesn't expose any item tables to give us specific average costs, our method is both necessary - and workable.


Cause 6. The last sentence in Cause 5 is the precise reason why our valuation by site may not be accurate. The quantity should be accurate.  However, since our methodology is based upon the actual posting amount per transaction, the valuation might be off a few pennies,


Cause 7. There should always be a 1 to 1 correlation between quantity and serial numbers.  Not having this correlation can cause quantity on hand errors.   This is just a limitation of how the data is exposed by Intuit to developers.



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