Overview
You have an error in the QQube Synch log:
SybaseSession_ExecuteNonQueryCommand
ExecuteNonQuery
Index 'mvf_FINANCIALTBA' for table 'mvf_FINANCIALTBA' would not be unique
refresh materialized view "mvf_FINANCIALTBA"
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
***OR***
SybaseSession_ExecuteNonQueryCommand
ExecuteNonQuery
Index 'mvd_Item' for table 'mvd_Item' would not be unique
refresh materialized view "mvd_Item"
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
***OR***
SybaseSession_ExecuteNonQueryCommand
ExecuteNonQuery
Index 'mvd_LINE_CHECK_SDK_LINE' for table 'mvdf_LINE_CHECK_SDK' would not be unique
refresh materialized view "mvdf_LINE_CHECK_SDK"
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
***OR***
SybaseSession_ExecuteNonQueryCommand
ExecuteNonQuery
Index 'mvd_LINE_VENDOR_CREDIT_SDK_LINE' for table 'mvdf_LINE_VENDOR_CREDIT_SDK' would not be unique refresh materialized view "mvdf_LINE_VENDOR_CREDIT_SDK"
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Cause
There are four possible causes:
- The first message listed above is the result of a 2001 bug in the Intuit Software Development Kit (SDK) which Intuit will most likely never fix. And only occurs when Financial Summary Data Models - or Financial Summary by Class Data Models are chosen.
- The second message listed above is the result of a limitation in the Intuit SDK and is the result of merging items. If the message above said mvd_Account, it would be the result of merging accounts. Ditto for Customers, Vendors, Classes - or any list in QuickBooks.
- The third message (it could be credit card charge/credit, bill, et.) listed most likely refers to cases where somebody has changed the name type, e.g. other name to vendor, or vendor to other name. The Intuit SDK doesn't tell us when this occurs, so we end up with two records using the same Unique Identifier - and we don't know which is the correct one.
- The fourth message is generally caused by an incorrect inventory/COGS entry within a Vendor Credit, if there is negative inventory or positive inventory.
Resolution
Cause 1. Make sure that the Accounting Preferences setting "Show lowest subaccount only" is UNchecked. Reload your QuickBooks data afterwards.
Then reload your QuickBooks data afterwards using the run all / clear all options.
It is only necessary to reload the Financial Summary Reports
Cause 2. There is only one way to fix this, and that is to reload the QQube Database from scratch as shown in the picture above using the Run All / Clear All options.
Cause 3. Reload the QQube Database from scratch as indicated in Cause 2. If you get the same error after rebuilding your QuickBooks file and reloading from scratch, please highlight the specific error log, and use the Send to CLEARIFY Support button to create a ticket and get further instructions.
Cause 4. Create a ticket following the information outlined here: QQube™ Support Options | CLEARIFY Submitting the log is the quickest way to create a ticket. Our engineers will give you instructions on getting the QQube database from you, and in most cases get a copy of the QuickBooks file. They will be able to tell you which offending transaction(s) need to be corrected.
NOTE: if we make arrangements to get a copy of your QB file, we are happy to sign any NDA for your organization.
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