Synch is Slow or Appears to Freeze

Modified on Sat, 29 Jun at 3:32 AM

Overview of Data Extraction in QQube Desktop

Extracting data on large files takes longer than expected or appears to freeze.  Refreshing updated data using the manual refresh option takes longer than several minutes. 


Cause

There is no direct connection to the database, and all developers (including raw connectors) must use the Software Development Kit (SDK) - built in 2001 - to extract data.


It is a slow and kludgy text-based extraction, and not a database connection extraction.  It will show a high CPU utilization, but normal memory usage.


But the good news is that the Intuit SDK never lies and is extremely secure.


The Intuit SDK was designed for putting data into QuickBooks - not extracting data out of it.


To further this conundrum, QQube extracts more data details from QuickBooks than any other developer in the Intuit Community.


If the QQube Configuration Tools says *Not Responding" it does NOT mean that the process is frozen or stuck.  It only means that the SDK is working overtime with QuickBooks to retrieve the data it wants.


Resolution

  1. Be patient. It is important to let the synch complete.  If you interrupt the process, you will have to reload everything from scratch again.
  2. Only choose the data models you need. One model is not dependent upon another.  For instance, if you want job costing, just load job costing, NOT sales, purchases, general ledger, etc. as that information is already included in the job costing data model. (See Selecting QuickBooks Data Models in QQube)
  3. Use the "Extraction Range" feature.  The QQube Configuration gives you the option of loading data just from a particular date.
  4. Initial Data Loads should occur overnight for files over 750 Meg.
  5. The faster the processor, the better the performance.  Time is money.  Don't put QQube on the "hand me down' machine.
  6. Be sure to allow for 3 to 8 gigs of memory on hosted environments.


Another Option for Large QuickBooks Files

If your file is one of the following:

  • QuickBooks Enterprise file over 1.25 Gig
  • QuickBooks Premier files over 350 Meg
  • QuickBooks file containing more than 10 years of data


Then we advocate getting someone like Matt Clark at https://www.qbornotqb.com to split your file into two files: (1) with old data, that you can open - or store in QQube, and (2) a current file for everyday day use.  DISCLAIMER: We do not receive kickbacks from this company - we recommend him because he has successfully taken care of hundreds of customers over the last decade and a half.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article