Error 800404(1D/30/35) - Unable to Auto Login

Modified on Sat, 29 Jun at 3:52 AM

Overview

You receive an error in the log that says:


<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 06:44:57 PM >>>>>>>>>>>>>>>>>>>>>>
QBXMLSession_OpenConnection
File named C:\Quickbooks\Rock Castle.QBW is not opened.
BeginSession
Error Code: 8004041D OR 80040430
This application is not allowed to log into this QuickBooks company data file automatically.
The QuickBooks administrator can grant permission for an automatic login through the
Integrated Application preferences.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

***OR***

<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 09:44:57 PM >>>>>>>>>>>>>>>>>>>>>>
QBXMLSession_OpenConnection
File named C:\Quickbooks\Rock Castle.QBW is not opened.
BeginSession
Error Code: 80040435
Recent changes to your configuration require you to go into the Integrated Applications
preferences and re-authorize your integrated application to login automatically.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

***OR***

<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 07:44:57 PM >>>>>>>>>>>>>>>>>>>>>>
QBXMLSession_OpenConnection
File named C:\Quickbooks\Rock Castle.QBW is not opened.
BeginSession
Error Code: 80040430
This application is unable to log into this QuickBooks company data file automatically.
The QuickBooks administrator must grant permission for an automatic login through the
Integrated Application preferences.
If such permission was already granted, the administrator must revoke permission,
save preferences, then grant the permission again.
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


Cause

These come directly from the Intuit Software Development Kit (SDK) and indicate that QQube is unable to auto-login to the requested QuickBooks file.


There are five possible reasons:

  1. Someone overwrote the existing QuickBooks file with a copy that did not authorize a QQube connection
  2. You have Pro/Premier and the permissions have been corrupted. ERROR CODE 80040435 ONLY.  
  3. Corruption of the QuickBooks Integrated Login.
  4. You updated from an existing release prior to 7.9x which contains a new Digital Certificate.
  5. You have more than one QQube Synchronizer running on the server or workstation.


Resolution

Cause 1

If you have a copy of QuickBooks that you receive from a branch, or other user, please do the following.  

  1. Login as admin to the QuickBooks file and first ensure that passwords for all users meet Intuit complex password requirements, including - and most importantly, the QQube user. (At least eight characters, at least one number, and at least one uppercase letter). 
  2. Then connect the file to QQube to establish the correct permissions, as shown here.


You can then give back the copy of the file to the branch, or other user, to allow them to continue to use QuickBooks, until you are ready to receive another copy at a later date.  This time, when you overwrite the current QB file, the proper permissions will already be in place.


Causes 2, 3, 4. If you have a multi-user version of QQube, then login to the server user where QQube installed (not your own user).

  • Go into QuickBooks under Edit>Preferences>Integrated Applications and remove the QQube Data Warehouse from the list and click ok - leaving the file open.
  • Login as the actual QQube user in QuickBooks to see if there are permission error messages from QuickBooks and follow the instructions presented at that time. (e.g. re-enter a complex password or create an Intuit e-mail).
  • To Re-Establish Permissions: Go into the QQube Configuration Tool > QuickBooks Company List and highlight the particular QuickBooks file.
  • Click on "Change Path" - as shown here:



Cause 5.  The synch takes place under the user where QQube is installed.  However, regular users, in a multi-user implementation, may erroneously attempt to run the synchronizer under their own user name (or erroneously install an update under their own user name causing the synch to auto kick off), and cause errors like this to occur.  A regular user is never a synch user unless you have a single-user on a workstation or laptop.  If you are unfamiliar with the proper implementation, please review our installation guides

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article