Error 80040440 - Missing Complex Password

Modified on Sat, 29 Jun at 3:50 AM

Overview

You have an error in the QQube Synch log:


<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 06:44:57 PM >>>>>>>>>>>>>>>>>>>>>>
QBXMLSession_OpenConnection File named F:\QB Data\Rock Castle.QBW is not opened.
BeginSession
Error Code: 80040440 Quickbooks can't return sensitive information, if company file is not
protected with a complex password

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


Cause

There are two possible causes:

  1. The user you designated for QQube to login to QuickBooks is not following the Intuit enforced password requirements of "a minimum of eight characters, at least one number, and at least one uppercase letter".
  2. QuickBooks Pro and Premier can throw a "false positive" error, whereby you are sure you have created the proper password for the specific QQube user you created, but the QQube Log shows the same SDK error.


Resolution

Cause 1

To fix this error you need to do two things:  

  1. Login to the machine user where you installed QQube and then login as Admin into QuickBooks.
  2. All users (including the Admin, and especially the auto-login QQube user) must have passwords that meet the Intuit complex password requirements. (A minimum of eight characters, at least one number, and at least one uppercase letter).


Cause 2

  1. Login to QuickBooks using the specific QQube user you created.
  2. QuickBooks will show a dialogue box asking you to change the password.
  3. Create a new password using the complex password requirement and save.

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