Multi-User Client Cannot See Server

Modified on Sat, 29 Jun at 2:50 AM

Overview

You install the QQube multi-user client and arrive at the screen where the QQube Engine Name gets populated with your network server name and address - and it is blank.



Cause

The IP Address and/or port is being blocked.  The QQube installer uses a Sybase Utility to "ping" the database server using UDP.


There are five potential reasons for this:

  1. Service not running on server
  2. Incorrect DNS settings on the server
  3. Workstation Firewall is blocking port 2638
  4. Server Firewall is blocking port 2638
  5. The workstation is on a different subnet


Resolution


Cause 1.  Login to the dedicated server synch user and open up the QQube Configuration Tool.  Go to Advanced Options>Database (Show More).  The Start Database Service should be greyed out.  If it isn't then exit the qqube synchronizer in the lower right-hand tray (right click on the lightning bolt and exit); then Start the Database Service.


Cause 2.  Open up a DOS Prompt Window and do a ping on the server name to see if it comes up with the expected IP address.  If it doesn't, please get with your IT personnel to troubleshoot and fix.


Cause 3. Temporarily disable the firewall on the workstation, then hit the "Back" button, and the "Next" button again to see if it finds the Server Engine Name.


Cause 4. If the resolution for Cause 2 did not work, then either temporarily disable the server firewall, or disable the firewall operation that prevents pings, and ports.



Cause 5. Use this procedure.

FIRST - cancel the current installation.


SECOND (OPTION FOR WORKSTATION) - open up a cmd window (with administrative rights) and run a switch (OVERRIDENODBSERVER=1) that will allow the installer to ignore the search.


SECOND (OPTION FOR SERVER) - the switch is (OVERRIDESERVERCLIENT=1): 


In these two examples above, the qqubeinstall.exe was placed in the Downloads directory; and run from that directory.


As you run through the installer, then you will notice that the "Next" button is now available in the Other Installation Options Window, even though there are no database servers found.


THIRD - once you complete the installation, run the QQube Configuration Tool.  It will return a message saying that it can't find the database server, and defaults to this window:


THIRD (CONTINUED) - Type in the name of the database server that you see in the QQube Configuration Tool on the server, then physically type in the IP Address and Port in the Server IP Address window.  Unless the database service is not running on the server, or your firewall is specifically blocking this port, this option will always work.

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