Error 80040418 - QuickBooks Permissions Missing

Modified on Sat, 29 Jun at 3:47 AM

Overview

You have an error in the QQube Synch log:


<<<<<<<<<<<<<<<<<<<<<< 10/15/2024 06:44:57 PM >>>>>>>>>>>>>>>>>>>>>>
BeginSession
Error Code: 80040418
This application has not accessed this QuickBooks company data file before. Only the
QuickBooks administrator can grant an application permission to access a QuickBooks
company data file for the first time

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<


Cause

This error comes directly from the Intuit Software Development Kit (SDK) and indicates that it does not have permissions from the requested QuickBooks file to communicate with it. 


There are two possible causes for this error:


1. The QB file has not assigned permissions for allowing QQube to connect - or they have been removed/revoked. 

This can happen if the users and permissions are not created and assigned per our create connection users guide, but more often than not, it happens because someone replaced the existing QB file, with one that never had the permissions assigned.


2. You have more than one QQube Synchronizer running on the server or workstation.



Resolution

Cause 1. Ensure that QuickBooks contains the following entry under Integrated Applications:



If it doesn't show like this, then you may need to re-establish the permissions between QuickBooks and QQube, by removing the company from QQube, and then re-adding the company in the same step.



Cause 2. The synch takes place under the user where QQube is installed.  However, regular users, in a multi-user implementation, may erroneously attempt to run the synchronizer under their own user name (or erroneously install an update under their own user name causing the synch to auto kick off), and cause errors like this to occur.  A regular user is never a synch user unless you have a single-user on a workstation or laptop.  If you are unfamiliar with the proper implementation, please review our installation guides. 

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